Control group / resource generator bug

Rather serious bug I almost forgot to mention. I believe it was in this game, Ga522b3f3afb84fe0beb1677a00cc5762.

I have the resource generator building/tab assigned to 4 as my standard hotkey (so 4 is not a control group for me). At one point in the game I accidentally tried to assign a unit(s) to 4 using ctrl-4. Following that, 4 failed to work properly by selecting the resources building/tab, but furthermore I couldn't even select the resources tab by clicking for the rest of the game. This left me unable to control my generator at all. Fortunately I discovered that the automatic generator production seems to have improved since I last tried it - for instance, when I was short on Energy it automatically built Energy multiple times in a row. Nonetheless, this is a pretty serious problem - not only did it mess up my hotkey, but it actually messed up the clickable button somehow as well.


  • BKcoreBKcore Member, Administrator

    Good catch! thanks.

  • MutableManMutableMan Member, Administrator

    Thanks for finding this and the detailed report! I'll work on a fix for this.

Sign In or Register to comment.