Audio bug - unplugging headphones

During game G1c826e221c6947ae98a9e82119ec6a85 I was playing and decided at the start to switch from headphones to earbuds (my hair was wet), after I unplugged the headphones the audio never returned to the earbuds. I checked and audio was getting through the computer to the earbuds and I even switched back to the headphones and it never returned. I also tried muting the audio and changing the audio settings a few times but nothing brought it back.


  • MicahMicah Member, Administrator

    Ghost_stalker -- I'd like to reproduce this on my development PC as closely as possible to debug it.

    Can you explain how your various audio devices (even those that are not involved in the bug report) are connected?

    Are your headphones connected by USB or a 1/8" stereo jack? Which one was selected as default in the OS? Was Atlas configured to play out of the "Default device" or was it specifically choosing your headphones by name?

  • I only have one audio device at the moment. My Steelseries headphones with the built in mic. They use a 1/8" stereo jack. Originally is "Auto/ Follow OS Default" but switched to "Speakers / Headphones (IDT High definition Audio CODEC)" after and back without result.
    That said, I just tested having "Speakers / Headphones (IDT High definition Audio CODEC)" selected first when I pull the plug and the audio did cut out but then upon selecting the only option there after plugging it back it, the audio came back. Then then I did it again on "Auto/ Follow OS Default" it wouldn't come back no matter which option I selected.
    Come to think of it there were still two options when I unplugged my headphones the second time but only one the first time. I have the dxdiag file for my computer prior to this test made up if you want me to send it to you over discord or such.
    Also, apologies for such a late reply.

  • MicahMicah Member, Administrator

    Ooh, is there any chance you've upgraded to Win10 and it didn't automatically upgrade the driver for your motherboard / laptop audio codec?

    Here's a reddit thread where a guy reports that his computer was failing to detect an attached audio device and fixed it with an update. Lots of people have chimed in with a "me too" about it fixing similar problems.

    Apparently each system maker (HP, Dell, etc) need to issue an update for their pinouts so it can't come as an update straight from microsoft.

  • Ghost_StalkerGhost_Stalker Member
    edited July 9

    Actually, that's on my to do list. I'm still running Windows 8.1. Maybe that is it.
    I'll try updating my motherboard configurations (and anything else I can think of) anyway tomorrow. Sorry if I made this a wild goose chase for you.

  • MicahMicah Member, Administrator

    Thanks for engaging on this -- not a goose chase at all. If you have this problem, someone else probably will too :)

  • I've tried to update my motherboard but there is no newer version for that specific board ID. I've tried to update my audio drivers manually and automatically many different way without success. I still think that it is the audio drivers but I'm just going to leave it for now. Most of all, I have confirmed that this behaviour does happen in some other games as well, but not all. Therefore, I think it's safe to say that it's specific to my computer and not worth pursuing further. Thanks for your help and if I do figure out what it is, I'll post the solution. Probably will be upgrading to Windows 10 soon so here's hoping it doesn't make things worse. Cheers.

Sign In or Register to comment.