How I got Error Code: Eggplant working

ZenoSpyridonZenoSpyridon Member
edited December 2015 in Help & Support

I was having a "Error Code Eggplant" issue on my laptop (which seems to be very common), where if I put it on integrated graphics it would work, but if I attempted to put it on high performance/Radeon graphics it would not work. I'm currently on Windows 10 64bit.

Tried many work-arounds and finally found something that worked. It seems part of the issue is not just the Radeon driver but also the Intel driver. I noticed that some other Atlas exe's were added to the "recent applications" section of switchable graphics as well, and think that may have helped.

Here are the steps that worked for me:

1) Run as Admin > Installed Radeon driver 15.11 (most recent non-beta, full install). I let the application on the official website auto detect the version for me. Make sure to right click > run as admin to avoid any possible errors.

2) Right click start menu > Control Panel > Hardware and Sound > select "Device Manager" underneath the "Devices and Printers" heading. Right click on Intel(R) HD Graphics 4000 > Update Driver Software > Browse my Computer > Let me pick from a list > Now choose Intel HD Graphics 4000 version This is important, as the current version and the ones newer and older were not working for me. This is the only one that worked out of them for me.

3) On the Intel HD Graphics Control Panel, go in to "3D" and make sure it is set to Application Optimal Mode > Enable, and General Settings > Performance. Save your changes.

4) On the AMD Settings application hit preferences on bottom > Radeon Additional Settings > Switchable Graphics Settings. You will want to set your atlasclient.exe (found in Atlas/game-client/atlasclient.exe), coherentui_host.exe (found in Atlas/native-client/host/coherentui_host.exe) and AtlasRunner.exe (found in Atlas/native-client/AtlasRunner.exe) to "High Performance" mode.

5) Restart your PC to make sure all of these changes saved.

6) Right click > Run as admin the Atlas launcher.

And the game is now working for me properly in high performance mode.

Hope this could help someone else out! It definitely helped me enjoy the game more with the controls now feeling smoother. Please let me know if it does (or does not) fix your issues, or if you found any additional issues/workarounds!

Sign In or Register to comment.